Picture of CA Edington
Uploading Users
by CA Edington - Saturday, 7 April 2007, 11:26 AM
 
I'm sure this question is a simple one, but - thanks to the questions by beginners posted to the Forum (and Peter's thorough but concise answers) - I'm feeling braver about asking questions that are slightly above beginning level.

In this case, I want to upload users, but not one at a time.  Since I don't know the names of the students, yet, I will be creating "dummy users," such as Fuji1, Fuji2, Fuji3, and so on.

Since this will mean uploading 90+ users, I'd like to know the easiest, fastest way to do it.  I have gone to Administration ---> Users --> Accounts --> Upload Users.  There's a message "place to Browse for a File, and a message " No file was found - are you sure you selected one to upload?"

I didn't select a File because I haven't created one.  Can anyone help me with the next step?

Appreciatively yours,
CA (who's on a Marathon Moodle weekend, getting ready for classes on Monday)

Picture of CA Edington
Re: Uploading Users
by CA Edington - Saturday, 7 April 2007, 12:51 PM
 
It may seem as though I'm talking to myself here, but actually I'm not!

Bob Gettings wrote me a private message pointing out that I could find the answer to my own question by clicking on the little question mark next to Upload Users - duh! (although Bob put it in a much gentler way).

So it seems that if I make a csv (comma separated variables) Excel file with the fields <username, password, firstname, lastname, email>, that will do the trick.  I haven't had much experience with Excel, but I'll be trying that.  Sounds easy enough.  Hah!

CA
http://www.caezplace.com/moodle2/course/view.php?id=22




Picture of Peter Ruthven-Stuart
Re: Uploading Users
by Peter Ruthven-Stuart - Monday, 9 April 2007, 02:41 PM
 
CA,

By the looks of it, you've already found the relevant help file, but for others the 'Upload users' help page in the English Forum Moodle is here:

http://englishforum.sgu.ac.jp/moodle/help.php?file=uploadusers.html

What you need to do:
  1. in an Excel file, type in the field names: at the very minumum you need:
    • username, password, firstname, lastname, email
      • this is all explained in the above help page
  2. Save your file as an Excel file
  3. Re-save your file as a CSV file (comma delimited)
  4. If you have Japanese characters in the file, re-open it in a text editor and then re-save it in Unicode (UTF8) encoding - ignore this step if the file is all roman characters.
  5. upload the file to your Moodle via the upload users page
For generating a random list of 'safe' passwords, this URL might be useful:

http://www.pctools.com/guides/password/

and for generating random names (not really necessary, but fun):

http://dir.yahoo.com/Entertainment/Humor/Names/Name_Generators/

That's it thoughtful
Picture of CA Edington
Re: Uploading Users
by CA Edington - Monday, 6 April 2009, 11:34 AM
 
One would think I'd know how to upload a list of users by now, but I haven't done it for at least a year and am running into problems - again. blush

I made a comma-delineated list in Excel as follows:

Excel File CVS

When I try to upload it, I get this error message:

Invalid CSV File Format

Does any of you brilliant people have a suggestion?

Picture of Don Hinkelman
Re: Uploading Users
by Don Hinkelman - Monday, 6 April 2009, 11:50 AM
 
Brilliant person here with suggestion....

You may have a mismatch of the csv delimiters. Is Excel file and the moodle setting on this screenshot both using comma delimiters?



Picture of CA Edington
Re: Uploading Users
by CA Edington - Monday, 6 April 2009, 12:30 PM
 
Thanks for replying, brilliant person! wink

I saved the Excel file as CVS, and the Moodle setting is similar to the one in your screenshot except for the number of megabytes, which shouldn't be the problem.

Upload Users

[insert emoticon for puzzled]

Picture of Eric Hagley
Re: Uploading Users
by Eric Hagley - Monday, 6 April 2009, 01:43 PM
 
Try increasing the number of preview rows.
Also, when saving the cvs file, there should be an option "edit filter settings". Choose this.
In the field delimiter you should use a comma but with the text delimiter, ensure it is blank.
Just refreshing my memory myself!
Picture of CA Edington
Re: Uploading Users
by CA Edington - Monday, 6 April 2009, 02:43 PM
 
Eric: Try increasing the number of preview rows.

CA: I tried that already. Didn't work.

Eric: Also, when saving the csv file, there should be an option "edit filter settings". Choose this.

CA: I'm saving as a csv file in Excel but don't see any such option.

Eric: In the field delimiter you should use a comma but with the text delimiter, ensure it is blank.

CA: I'm supposed to be putting commas after username and the like? When I tried doing that, I got the error message
""username" is not a valid field name".

Geesh! I should have learned this stuff in Moodle 102. I guess I'll have to retake the course. Anyway, I'll try again later today (unless someone wants to become an Administrator on my site temporarily?).

Thanks, as always, for your time, the brilliant Eric and Don (and offlist Bob G., from whom I was reminded that this is CSV, not CVS like the drugstore CVC in the Boston area).


Picture of Eric Hagley
Re: Uploading Users
by Eric Hagley - Monday, 6 April 2009, 03:02 PM
 
Perhaps you should try it with neo office for the mac - free equivalent of Microsoft's office. I think your problem is in the text delimiter - "" are automatically added or some other character set. Moodle doesn't like them. These are automatically done so you shouldn't be putting them in yourself.
Picture of Don Hinkelman
Re: Uploading Users
by Don Hinkelman - Monday, 6 April 2009, 03:43 PM
 
I have used excel csv in the past to upload users with no trouble. So why don't you send me your file by email and I will try doing it. Also, please let me know what version of Moodle you are uploading to.
Picture of CA Edington
Re: Uploading Users
by CA Edington - Monday, 6 April 2009, 03:48 PM
 
Eric - I got the error message after I read what you wrote [below] and thought I was supposed to put commas in the field delimiter. But I got an error message either way. The other was the one I posted before:

Invalid CSV File


Eric:
In the field delimiter you should use a comma but with the text delimiter, ensure it is blank.

CA: I'm supposed to be putting commas after username and the like? When I tried doing that, I got the error message
""username" is not a valid field name".

I know I've done this before with Excel, and it should be a simple process. sleepy
Picture of CA Edington
Re: Uploading Users
by CA Edington - Monday, 6 April 2009, 04:07 PM
 
Problem solved! What I was doing was trying to upload the Fuji “dummy names” and the Sapporo University “dummy names” from the same list. For some reason, Moodle didn't like that. (Notice my high tech language here.) When I tried to upload them as two separate lists, it worked like a charm!

So sorry to bother you guys with all this back and forth, but it's always a learning process, right?

Thanks so much for being here!
kiss